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Entry point not found, the procedure entry point could not be located

Troubleshooting


Problem

Attempts to upgrade IBM Rational ClearCase on Microsoft Windows results in the error "Upgrade error - Entry point not found, the procedure entry point could not be located."

Cause

This issue has been known to occur under either of the following circumstances:

Cause #1:
Prior to the upgrade, ClearCase is installed using an incorrect uninstall executable (from a different release for example) resulting in uninstalled DLLs. If, after the upgrade, the system path lists the old location of the DLLs before the new location, the incorrect DLLs will be found, resulting in the error.


Cause #2:
ClearCase is installed into a new location without the release from the old location being removed.


Cause #3:
If the problem is seen when upgrading ClearCase version 7.0 or 7.0.1, the error could also happen if you do not create a new separate release area for a new Fix Pack.

The following is noted in the Creating a release area section of the ClearCase 7.0 and 7.0.1 Installation and Upgrade Guide (Windows) under the topic of Applying a fix pack to a release area:

Applying a fix pack to a release area: If you want to apply a fix pack to the Rational products in your environment, you must re-create the release area as if users are installing the products on their desktops for the first time. This new release area is used to update and install Rational desktop products.
After you create this new release area, disable the old one. Disabling the old release area prevents access to the previous version of Rational products and allows access if users need to restore a system to the previous version of Rational products.

Resolving The Problem

Apply one or more of the following steps which matches the cause above:

Solution #1:

Check for and remove old ClearCase DLLs (look in the system32 directory or other locations in the System Path).

Note: To verify that any DLLs are old, compare the suspected DLL to the location and time stamp of a similarly named DLL on a working machine. The ccasenp.dll and ccnotify.dll DLLs relate to ClearCase in the system32 directory.

Solution #2:

Uninstall both installations with the correct uninstall executable (found in the release area of the release in question), and then install the desired release.

Solution #3:

Either create a separate patched release area as per the instructions in the Installation and Upgrade guide, or manually uninstall after reviewing technote 1179647: How to manually uninstall ClearCase on Windows to remove the old release completely.

Review technote http://www.ibm.com/support/docview.wss?uid=swg21242322">1242322: Applying a Rational iFix or Fix Pack on Windows for more information about applying fix packs.

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Document Information

Modified date:
16 June 2018

UID

swg21148737