Troubleshooting
Problem
Entity changes are not getting captured while using Change Project Management feature in IBM Sterling Order Management
Symptom
"Change Project doesn't have any changes to approve" error is displayed when we try to "Approve" the changes and hence unable to proceed.
Cause
Change Project Rules have not been defined in the environment as a result of which "YFS_ENTITY_CHANGE" table doesn't have the changes captured in turn resulting in this error.
Resolving The Problem
1) Create changeDataManagementRules.xml:
Please refer the product documentation to know more about the parameters here.
Sample Snippet:
<ChangeDataManagementRules DeploymentName="STAGING">
<Rules>
<Rule Name="MaintainEntityChanges" Value="Y">
<TableTypeList>
<TableType Type="CONFIGURATION"/>
<TableType Type="MASTER"/>
</TableTypeList>
</Rule>
<Rule Name="EnableChangeProjectManagement" Value="Y"/>
<Rule Name="ChangeProjectIDPrefix" Value="ST"/>
<Rule Name="ExportChangeProjects" Value="N"/>
<Rule Name="PreventTableImport" Value="Y">
<TableList>
<Table Name="YFS_AUDIT"/>
</TableList>
</Rule>
</Rules>
</ChangeDataManagementRules>
2) Place the xml under
<install_dir>/extensions/global/template/resource directory.
3) Run deployer.sh -t resourcejar from the bin directory of the installation directory.
4) Rebuild your EAR.
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Document Information
Modified date:
16 June 2018
UID
swg22001219