IBM Support

Enabling Topoviz tracing and debug.

Question & Answer


Question

IBM Support asked me to enable extra logging and tracing on Topoviz, how do I do that?

Cause

Topoviz is responsible for displaying the visual elements of the network, like Hop Views and Network Views.
IBM Support might ask you to enable trace and debug on Topoviz for troubleshooting.
The Topoviz log and trace files are located under the installation directory for the Tivoli Network Manager GUI components.  It is referred to as $NMGUI_HOME in the documentation.
Read the documentation on locating the log and trace files:
https://www.ibm.com/support/knowledgecenter/SSSHRK_4.2.0/admin/task/adm_locatingguilogfiles.html
There are three methods.
Methods 2 and 3 do not require a restart of JazzSM or TIP.
However, method 2 or 3 does not increase the size of the log or trace files created.
The default log file size is only 10 megabytes.
Topoviz creates large numbers of diagnostic messages.
The log and trace files can be overwritten quickly.
Update:  Method 3 has not been verified to work in JazzSM.

Answer

 
Method 1, Topoviz.properties.
Edit the file called topoviz.properties.
Alter these settings;
topoviz.log.level=FINEST
topoviz.log.maxsize=100
topoviz.log.count=10

topoviz.trace.maxsize=100
topoviz.trace.count=10
topoviz.trace.level=FINEST

Stop the JazzSM server.
Remove the files called ncp_topoviz.0.log and ncp_topoviz.0.trace
Start the JazzSM server.

Review the documentation for the location of topoviz.properties
https://www.ibm.com/support/knowledgecenter/SSSHRK_4.2.0/admin/task/adm_locatingguilogfiles.html

Log in to DASH and once the problem recurs capture the ncp_topoviz.0.log and ncp_topoviz.0.trace files and send them to IBM Support.

Method 2, WebSphere Administrative Console.
Log in to the Dashboard Applications Services Hub (DASH) or Tivoli Integrated Portal (TIP) server and navigate to the WebSphere Administrative Console from the left side panel.

Settings > WebSphere Administrative Console

Click "Launch WebSphere administrative console". You are presented with an Integrated Solutions Console (ISC) login screen. Log in using your tipadmin credentials.

In the ISC left side panel, choose:

Troubleshooting > Logs and Trace

On the right side panel, choose the appropriate server.  The default is 'server1'.

server1 > Change Log Detail Levels

You are presented with a panel with two tabs, "Configuration" and "Runtime". Click the "Runtime" tab.

Alter the value in the box so that it reads as follows:

*=info: topoviz.log.level=finest: topoviz.trace.level=finest

Once the change is made, click "Apply", then "OK".  Now you can log out of the console.
See the attached gif file for a demonstration.
To remove the setting, set the value back to its original value, or restart the DASH or TIP Server.  Changes to the Runtime tab do not persist over a restart.


 
Method 3, wsadmin facility.
Open a command-line console on the DASH or TIP server.
Locate wsadmin.sh.
You need the smadmin or tipadmin password

./wsadmin.sh -user tipadmin -password <your tipadmin password>

If you connect successfully, you see a prompt like this;

[root@thebe bin]# ./wsadmin.sh -user tipadmin -password netcool
WASX7209I: Connected to process "server1" on node TIPNode using SOAP connector; The type of process is: UnManagedProcess
WASX7029I: For help, enter: "$Help help"
wsadmin>


At the wsadmin> prompt, enter the following:

1) set server [$AdminConfig getid /Server:server1/]
2) set ts [$AdminConfig list TraceService $server]
3) $AdminConfig modify $ts {{startupTraceSpecification topoviz.trace.level=FINEST=enabled}}
4) $AdminConfig modify $ts {{startupTraceSpecification topoviz.log.level=FINEST=enabled}}
5) $AdminConfig save
6) exit
7) restart the TIP server


To back-out these changes, rerun the commands changing FINEST to INFO.

 

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSSHRK","label":"Tivoli Network Manager IP Edition"},"ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"3.9;4.1;4.1.1;4.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
07 January 2021

UID

swg21646370