Troubleshooting
Problem
With SSO enabled, users hitting the gateway will receive an HTTP 500 error.
Cause
Server variable was missing.
Diagnosing The Problem
Receives an HTTP 500 error when trying to access Cognos via SSO.
In Internet Information Services Manager (IIS) review whether the HTTP_X_BI_PATH Server Variable exists.
- launch IIS
- Expand the Server Name
- Expand the Website
- Expand ibmcognos (or the alias that you have chosen)
- Click on the BI server folder
- Double-click the URL Rewrite
- Click Add
- Click Blank Rule
9. Expand Server Variables
10. Click Add
A Dialog Box should appear.
11. Drop down the list of Server Variable names.
HTTP_X_BI_PATH is missing when it should be defined.
Resolving The Problem
1. Ensure SSO is set up according to this document:
Cognos 11.0.0. - 11.0.3 http://www-01.ibm.com/support/docview.wss?uid=swg21976435&aid=1
Cognos 11.0.4 - https://www.ibm.com/support/knowledgecenter/SSEP7J_11.0.0/com.ibm.swg.ba.cognos.inst_cr_winux.doc/t_sso_actdirserver.html
2. Verify all proxy variables are set up correctly
3. In IIS -> Click the /ibmcognos application> Click the BI folder -> Double click URL Rewrite -> Click "View Server Variables" on the far right -> Ensure the HTTP_X_BI_PATH variable exists if not create it
4. If it did not exist once it is created click back to rules for:
11.3 - Double-click the Headers rule under server variables delete the existing HTTP_X_BI_PATH variable and recreate it setting the value to /alias/bi/v1
11.4 - Double-click the Inbound Rule under server variables delete the existing HTTP_X_BI_PATH variable and recreate it setting the value to /alias/bi/v1
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Document Information
Modified date:
15 June 2018
UID
swg21992383