Troubleshooting
Problem
User launches TM1 client. User tries to connect to a TM1 instance (also known as TM1 server). An error appears.
Symptom
![image-20190121072647-1](/support/pages/system/files/inline-images/image-20190121072647-1.png)
E4) Cannot connect to admin server at host <servername> and port "5498"
Cause
There are several possible causes for why a TM1 client cannot connect to a TM1 instance (server).
This Technote specifically relates to the scenario where the cause is that there is a problem with the TM1 SSL certificates, caused by the fact that older versions of TM1's SSL certificates expired on November 24th 2016 .
Environment
Older TM1 server and client versions, for example TM1 10.2.2.
Diagnosing The Problem
Resolving The Problem
Update the SSL certificate on both:
(a) The TM1 server
(b) The TM1 clients.
Steps:
There are several different methods available to update the SSL certificate (on both the server and client).
- The simple steps below are suitable for most customers
- For more in-depth instructions, see separate IBM Technotes (for example #1990334 & #1991653).
TM1 Server:
1. Download the updated certificates file ("NewSSLCerts.zip")
- TIP: For a link, see section "Updated TM1 SSL Certificates Download Location" inside Technote #1991653.
2. Perform the instructions specific to your exact version of TM1 server (for example 10.2.2)
- TIP: See section "IBM Cognos TM1 Server Side Updates / Steps" inside Technote #1991653.
TM1 Client:
For most customers, simply need to perform the following:
1. Extract the file 'NewSSLCerts.zip' somewhere sensible (for example C:\TEMP\NewSSLCerts)
2. Copy the contents of that folder (C:\TEMP\NewSSLCerts\*.*) and paste them into the following two folders:
<tm1_install_dir>\tm1_64\bin\ssl
<tm1_install_dir>\tm1_64\bin64\ssl
1. Extract the file 'NewSSLCerts.zip' somewhere sensible (for example C:\TEMP\NewSSLCerts)
2. Copy the contents of that folder (C:\TEMP\NewSSLCerts\*.*) and paste them into the following two folders:
<tm1_install_dir>\tm1_64\bin\ssl
<tm1_install_dir>\tm1_64\bin64\ssl
3. Double-click on the following file: <tm1_install_dir>\tm1_64\bin64\ssl\uninstallSSL.bat
4. Double-click on the following file: <tm1_install_dir>\tm1_64\bin64\ssl\importsslcert.exe
4. Double-click on the following file: <tm1_install_dir>\tm1_64\bin64\ssl\importsslcert.exe
[For more/full details , see section "IBM Cognos TM1 Client Side Updates / Steps" inside Technote #1991653.]
Related Information
[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
21 January 2019
UID
ibm10796050