IBM Support

DPR-ERR-2056 when executing reports after updating Symantec Endpoint Protection

Troubleshooting


Problem

After Symantec Endpoint Protection updates, any report that executes results in an error message.

Cause

The BIBusTKServerMain will be prevented from being launched by the product.



Symantec identifies DLLs in the <cognos install>/bin directory as "WS.Reputation.1". Which does according to the description of this identification, is beyond the traditional signatures and behaviour-based detection, it uses a reputation-based system which polls individuals.


[code]https://www.symantec.com/security_response/writeup.jsp?docid=2010-051308-1854-99[/code]

Environment

Windows

Diagnosing The Problem

Symantec Endpoint Protection's risk logs will identify DLLs in the <cognos install>\bin as infected with "WS.Reputation.1".

Executing reports gives the error message gives the error message of:
DPR-ERR-2056 The Report Server is not responding.

The cogserver/cogaudit.log will contain the error:
CCL-PLG-0001 Failed to load the pluggable shared library

Resolving The Problem

Have your Security Administrator review the scan.

At which point, they will need to exclude the Cognos directory structure (and subfolders) from the scan.


Restore the quarantined files.


Restart the product.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration and Configuration v11x","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0.9;11.0.8;11.0.7;11.0.6;11.0.5;11.0.4;11.0.3;11.0.2;11.0.1;11.0","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22013979