IBM Support

DOORS 9.5 and later needs direct internet access to access Help by default

Question & Answer


Question

Why is direct access to the internet needed with IBM Rational DOORS 9.5 and later, when previous versions could access the help fine in environments that have no internet access or require a proxy server to access the internet?

Cause

As of IBM Rational DOORS 9.5, the default was changed from Local Help to Remote Help. The default Remote Help configuration requires direct access to the internet.

Answer

In DOORS 9.5, a design change was made in the DOORS client, and the default was changed from Local Help to Remote Help. The default Remote Help expects a direct connection to the internet to work. As a result, users who require a proxy server to access the internet (or cannot access the internet at all) will need to manually reconfigure their Help preferences before they can use it. Unfortunately, there currently is no way to change the Help default or automate reconfiguring the Help for all users. We are working on adding this to an upcoming release.

In the meantime, rather than making all your users manually reconfigure the Help to use a proxy server, you may want to consider setting up an Intranet Help server -- this would only need to be done once, and reconfiguring the Help to point to the Intranet Help server is faster and easier than reconfiguring the Help to use a proxy server or setting up Local Help. In addition, using Intranet Help uses less disk space and is easier to manage than Local Help, because only one Intranet Help server -- as opposed to many Local Help setups -- would need to be upgraded upon upgrading DOORS. Please refer to the Intranet Help documentation in the DOORS 9.5.2 Info Center for further details.

Automation Note
The latest generally-available release of the DOORS client does not provide a means to automate reconfiguring the Help preferences. However, if you set up Intranet Help, you can engage IBM Services to automate reconfiguring the users' Help preferences to point to the Intranet Help server.

[{"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"General Information","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.5;9.5.0.1;9.5.1;9.5.1.1;9.5.1.2;9.5.2;9.5.2.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
01 May 2020

UID

swg21671616