Troubleshooting
Problem
A new install of Impromptu Administrator 7.5 on Windows 7 64-bit operating system is unable to successfully connect to Oracle database using native database client or ODBC drivers. Errors encountered: Error number -4: DMS-E-CONNECTREJECT, A connection has been rejected by the remote interface during operation 'attach database'. ORA-12154: TNS:could not resolve service name DMS-E-DBDLL_NOTFOUND, The dynamic link library 'OCI.DLL' could not be located in the search path or one of its dependent dynamic link libraries failed to load.
Symptom
Issue only being encountered on a Windows 64-bit workstation. Same version of Impromptu and Oracle client on Windows 7 32-bit does not encounter the issues.
Cause
Oracle client support for 64-bit Windows a factor in Cognos connection successfully and Windows environment variables not correctly configured.
Resolving The Problem
Check and verify the following is in place for Cognos Impromptu to be able to connect to Oracle database.
Ensure a Cognos 7.5 supported version of Oracle client is installed and that the Oracle client is supported in Windows 64-bit workstation.
Windows PATH variable contains the path to the Oracle client. Example: C:\oracle\product\10.2.0\client_1\bin
NOTE: If multiple Oracle client versions are installed, ensure the version required by Cognos appears first in the path variable.
Create a new windows variable, TNS_ADMIN pointing to the path with the Oracle tnsnames.ora file. Example: C:\Oracle\product\10.2.0\client_1\network\admin
Version of Oracle database and client that are supported by Cognos 7.5 can be verified in the Supported Environments website.
Cognos Series 7 Software Environments
http://www-01.ibm.com/support/docview.wss?uid=swg27014445
To verify which versions of Oracle client are supported on Windows 7 64-bit operating system please refer to the Oracle website or Oracle Support services.
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Document Information
Modified date:
15 June 2018
UID
swg21660711