Question & Answer
Question
Even if database configuration parameter is set to AUTORESTART=YES, crash recovery does not occur on an inconsistent database. Following SQL1015N error may be recorded in db2diag.log file.
2020-12-14-22.47.48.569457+540 E87681325A612 LEVEL: Error PID : 45744206 TID : 51974 PROC : db2sysc 0 INSTANCE: db2inst1 NODE : 000 DB : SAMPLE APPHDL : 0-8427 APPID: XXX.XXX.XXX.XXX.61743.201214135817 AUTHID : DB2INST1 HOSTNAME: HOSTNAME1 EDUID : 51974 EDUNAME: db2agent (SAMPLE) 0 FUNCTION: DB2 UDB, base sys utilities, sqledint, probe:2535 MESSAGE : SQL1015N The database is in an inconsistent state. DATA #1 : String, 91 bytes Crash Recovery is needed. Issue RESTART DATABASE on this node before issuing this command.
Cause
When a database becomes inconsistent in a Db2 pureScale environment, crash recovery does not automatically occur even if AUTORESTART is set to YES. The following statement in the Knowledge Center applies to a member failure only and does not apply to inconsistent databases.
In a Db2® pureScale® environment, the automatic restart behavior changes. If a database member fails, member crash recovery is automatically initiated for that member. In addition, if both cluster caching facilities fail at the same time, group crash recovery is automatically initiated. During member crash recovery, no connections are allowed against the database through that member. An SQL1015N error is returned if you try to connect to the database through a member that requires crash recovery. If crash recovery fails, another attempt at crash recovery is made. If the second attempt at crash recovery fails, an ALERT is set for the member on the host where recovery fails and restart light for that member is performed on a different host.
Answer
Issue RESTART DATABASE command.
For example:
db2 restart database <database_name>
Related Information
[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"ARM Category":[{"code":"a8m500000008Pm3AAE","label":"PureScale"}],"ARM Case Number":"","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"}],"Version":"10.1.0;10.5.0;11.1.0;11.5.0;9.8.0"}]
Was this topic helpful?
Document Information
Modified date:
06 December 2022
UID
ibm16406258