IBM Support

[Db2] db2diag.log に記録される Sevre メッセージ (sqlerCallDL SQLZ_RC_NO_CONNECTION)

Troubleshooting


Problem

db2diag.log に LEVEL Severe、ZRC=0x8136001C=-2127167460=SQLZ_RC_NO_CONNECTION なメッセージが記録されることがあります。

Symptom

 db2diag.log に以下のようなメッセージが記録されます。このとき、Db2 サーバーで特に問題は見受けられません。
2020-05-26-09.04.01.296681+540 I3961A541            LEVEL: Severe
PID     : 22937822             TID : 21243          PROC : db2sysc 0
INSTANCE: db2inst1             NODE : 000           DB   :
APPHDL  : 0-18768              APPID: *LOCAL.db2inst1.200525234124
AUTHID  : db2inst1             HOSTNAME: host1
EDUID   : 21243                EDUNAME: db2agent (instance) 0
FUNCTION: DB2 UDB, routine_infrastructure, sqlerCallDL, probe:140
RETCODE : ZRC=0x8136001C=-2127167460=SQLZ_RC_NO_CONNECTION, SQLT_SQLJC
          "No connection"

Cause

EDUNAME から、これはデータベース接続でなくインスタンス・アタッチであることがわかります。
インスタンス・アタッチからの sqlerCallDL の呼び出しはスナップショット (get snapshot コマンドなど) の実行を示します。
このエラーはスナップショット実行中に、呼び出し元 (コマンド行プロセッサーなど) がスナップショットのデータをすべて受信する前に接続を終了した場合に記録されます。

Resolving The Problem

Db2 サーバーの問題を示すエラーではないため、サーバーとしては無視可能です。
バッチ・ジョブなどでスナップショットを実行している場合は、スナップショットの結果を確認してください。
お問合せ先
技術的な内容に関して、パスポート・アドバンテージの契約のもと Db2 テクニカル・サポートへお問い合わせください。
Db2 テクニカル・サポート

Document Location

Worldwide

[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"ARM Category":[{"code":"a8m500000008PmOAAU","label":"Monitors-\u003ESnapshot monitor"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 August 2023

UID

ibm16216106