IBM Support

[Db2] Db2 Windows 版でセットアップが起動しない

Troubleshooting


Problem

Db2 Windows 版をインストールするには、setup.exe からセットアップ・ランチパッドを起動します。
しかし、「管理者として実行」で setup.exe を実行して数分しても画面に何も表示されないことがあります。
注:Db2 のインストール・イメージをスペースを含むディレクトリー以下に配置した場合、現在のバージョン の setup はディレクトリーからスペースを取り除くようにエラーを報告して起動しません。
古いバージョンではセットアップ・ランチパッドは起動しますが、インストール・オプションが表示されず、インストールが開始できません。

Cause

Db2 Windows 版のセットアップ・ランチパッドは HTML アプリケーションです。
このため、何らかの問題により HTML アプリケーションが実行できない、またはセキュリティ・ソフトウェアなどで HTML アプリケーションの起動が抑止されている場合、Db2 セットアップ・ランチパッドは起動しません。
taskmanager - Db2 setup launch pad

Environment

Db2 Windows 版のみ

Resolving The Problem

セットアップ・ランチパッドが起動しない場合、以下のいずれかの方法でセットアップを完了できます。
 
  • 応答ファイルによるサイレント・インストール
    ランチパッドを経由せず、応答ファイルを利用して製品をインストールできます。
    1. Db2 をインストールするコンピューターに管理者としてログオンします。
    2. 以下のような応答ファイル (db2server.rsp) を作成します。
      PROD = DB2_SERVER_EDITION
      LIC_AGREEMENT=YES
      FILE = C:\Program Files\IBM\SQLLIB\
      INSTALL_TYPE = TYPICAL
      DB2_COPY_NAME = DB2COPY1
      DEFAULT_COPY = YES
      LANG = JP
      
      CREATE_ICONS = YES
      DEFAULT_INSTANCE=DB2
      
      INSTANCE=DB2
      DB2.NAME=DB2
      DB2.USERNAME=<Db2 起動ユーザー名。通常は db2admin>
      * DB2.DOMAIN=<(ドメインユーザーの場合)ドメイン名>
      DB2.PASSWORD=<Db2 起動ユーザーのパスワード>
    3. 作成した応答ファイルを指定してセットアップを開始します。
      setup -u db2server.rsp -t setup.trc -l setup.log
      応答ファイルによるインストールについては、マニュアルも参照してください。
      応答ファイルを使用した Db2 製品のインストール (Windows)
       
  • wininst コマンドによる GUI インストール
    ランチパッドを経由せず、wininst コマンドで Db2 セットアップ・ウィザード (GUI) を開始できます。
    なお、wininst.exe はインストール・イメージを展開したディレクトリー (SERVER_T や SERVER_DEC など) の db2/windows ディレクトリーに配置されています。
    1. Db2 をインストールするコンピューターに管理者としてログオンします。
    2. 以下のいずれかのコマンドでセットアップの GUI を起動します。
      新規コピーとしてインストールする場合
      wininst -e ese -t setup.trc -l setup.log
      既存のコピー (下の例では DB2COPY1) を上書きしてインストールする場合
      wininst EXISTING -e ese -t setup.trc -l setup.log -n DB2COPY1
      Db2 コピーの概念はマニュアルの以下のページを参照してください。
      複数 Db2 コピーの概要
    3. 起動したセットアップ・ウィザードの指示に従い、インストールを完了させます。
お問合せ先
技術的な内容に関して、パスポート・アドバンテージの契約のもと Db2 テクニカル・サポートへお問い合わせください。
Db2 テクニカル・サポート

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"ARM Category":[{"code":"a8m500000008PknAAE","label":"Install\/Migrate\/Upgrade"}],"ARM Case Number":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions"}]

Document Information

Modified date:
15 August 2023

UID

ibm16592479