Troubleshooting
Problem
In some conditions, a database cannot be activated with SQL1042C. The db2diag log shows log control files (SQLOGCTL*) gives DIA8402C A disk error has occurred due to open() subroutine returns EPERM (1).
Symptom
Users cannot connect to the database with SQL1042C. The db2diag.log shows Db2 cannot open log control files due to EPERM like as below:
2024-02-25-14.54.40.885298+540 E13780957E1145 LEVEL: Error (OS)
PID : 7632 TID : 140292510443264 PROC : db2sysc 0
INSTANCE: db2inst1 NODE : 000 DB : SAMPLE
APPHDL : 0-5627 APPID: *LOCAL.db2inst1.240225055440
AUTHID : APPUSR HOSTNAME: host01
EDUID : 4809 EDUNAME: db2agent (SAMPLE) 0
FUNCTION: DB2 UDB, oper system services, sqloopenp, probe:80
MESSAGE : ZRC=0x860F0004=-2045837308=SQLO_DGFL "general failure (DD)"
DIA8402C A disk error has occurred.
CALLED : OS, -, open OSERR: EPERM (1)
DATA #1 : Codepath, 8 bytes
4:11:15:24:40
DATA #2 : File name, 51 bytes
/data/db/db2inst1/NODE0000/SQL00001/SQLOGCTL.GLFH.1
2024-02-25-14.54.40.977751+540 E13788868E1145 LEVEL: Error (OS)
PID : 7632 TID : 140292510443264 PROC : db2sysc 0
INSTANCE: db2inst1 NODE : 000 DB : SAMPLE
APPHDL : 0-5627 APPID: *LOCAL.db2inst1.240225055440
AUTHID : APPUSR HOSTNAME: host01
EDUID : 4809 EDUNAME: db2agent (SAMPLE) 0
FUNCTION: DB2 UDB, oper system services, sqloopenp, probe:80
MESSAGE : ZRC=0x860F0004=-2045837308=SQLO_DGFL "general failure (DD)"
DIA8402C A disk error has occurred.
CALLED : OS, -, open OSERR: EPERM (1)
DATA #1 : Codepath, 8 bytes
4:11:15:24:40
DATA #2 : File name, 51 bytes
/home/db2inst1/NODE0000/SQL00001/SQLOGCTL.GLFH.2
2024-02-25-14.54.41.896023+540 I13839308E922 LEVEL: Severe
PID : 7632 TID : 140292510443264 PROC : db2sysc 0
INSTANCE: db2inst1 NODE : 000 DB : SAMPLE
APPHDL : 0-5627 APPID: *LOCAL.db2inst1.240225055440
AUTHID : APPUSR HOSTNAME: host01
EDUID : 4809 EDUNAME: db2agent (SAMPLE) 0
FUNCTION: DB2 UDB, base sys utilities, sqeLocalDatabase::FirstConnect, probe:11237
DATA #1 : SQLCA, PD_DB2_TYPE_SQLCA, 136 bytes
sqlcaid : SQLCA sqlcabc: 136 sqlcode: -1042 sqlerrml: 0
sqlerrmc:
sqlerrp : SQLEDINT
sqlerrd : (1) 0x00000000 (2) 0x00000000 (3) 0x00000000
(4) 0x00000000 (5) 0x00000000 (6) 0x00000000
sqlwarn : (1) (2) (3) (4) (5) (6)
(7) (8) (9) (10) (11)
sqlstate:
DATA #2 : Boolean, 1 bytes
false
Cause
Some antivirus or security software might prevent Db2 to access the control files.
Several users have reported McAfee antivirus causes this issue.
Resolving The Problem
Db2 users need to exclude the following paths from scanning by antivirus or security software applications.
- Db2 install path
Run db2ls command to list all the install paths.$ db2ls
- Instance path
Run db2greg command to list all the instance paths$ db2greg -dump | grep "^I,DB2"
- Database paths
Connect to the database, then query DBPATHS administrative view to list all the paths for the database.$ db2 connect to <db_name> $ db2 "select * from sysibmadm.dbpaths"
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"ARM Category":[{"code":"a8m500000008PkgAAE","label":"Database Objects"},{"code":"a8m500000008PmcAAE","label":"Recovery-\u003ELogging"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
26 March 2024
UID
ibm17145211