IBM Support

Db2 Automatic Client Reroute: Alternate server list (srvrlst.xml) contains an incorrect or unresolvable hostname

Troubleshooting


Problem

When using the Db2 Automatic Client Reroute feature, upon the first successful connection to a server, the client creates a local cache file containing alternate servers to connect to in case the primary server encounters a problem. This file is called srvrlst.xml.

The client updates the file with the server's list of available alternate servers. The hostname for alternate server B will match the hostname specified in the UPDATE ALTERNATE SERVER FOR DATABASE command, however the hostname for alternate server A (the primary server) may differ from the hostname specified for the original database connection. If a hostname in the alternate server list is not resolvable by the client, then connection issues may occur.
 

Symptom

The srvrlst.xml will look like the following example below. In this case, the client connected to database host 9.30.218.72, however sample1.fyre.ibm.com was returned as alternate server A (the primary server). If the server can resolve sample1.fyre.ibm.com (its own hostname), but the client can not, then connection issues may result.

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<configuration>

  <databases>
    <database host="9.30.218.72" name="SAMPLE" port="50000">
      <acr>
        <alternateserverlist>
          <server hostname="sample1.fyre.ibm.com" name="A" port="50000"/>
          <server hostname="9.26.121.209" name="B" port="50000"/>
        </alternateserverlist>
      </acr>
    </database>
  </databases>

</configuration>

Cause

This behaviour is working as designed. When the server prepares the alternate server list to send to the client, the server will attempt to resolve its own IP address to a fully qualified hostname. If the IP address can be resolved to a fully qualified hostname, then the hostname will be returned to the client. Otherwise, the IP address will be returned to the client.

Resolving The Problem

If the hostname returned can not be resolved by the client, either the hostname of the server must be changed, or the DNS configuration of the client must be modified so the client can resolve the hostname.

As a workaround, the client can add the unresolvable host name and the IP address of the server to their hosts file. The hosts file is located in the following locations:
  • Windows: C:\Windows\System32\drivers\etc\hosts
  • Unix and Linux: /etc/hosts

Document Location

Worldwide

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Document Information

Modified date:
30 January 2019

UID

ibm10869774