IBM Support

DB2 9.7 Backups fail after Upgrading Backup-Archive client to 7.1.8/8.1.2

Troubleshooting


Problem

DB2 9.7 API backups to an IBM Spectrum Protect Server fail after Upgrading the client to 7.1.8/8.1.2 or higher

Symptom

'db2 connect to <dbname>' or 'db2 backup db...use tsm' on a DB2 9.7 instance will fail with the following:
SQL2071N An error occurred while accessing the shared library
"/db2/<instance>/sqllib/adsm/libtsm.a". Reason code: "2".

dsierror.log logs the following error :

ANS1579E GSKit function GSKKM_ImportKeys failed with 17: GSKKM_ERR_DATABASE_INVALID_FILE_TYPE

This error occurs despite following the steps in the Client guide to change the symbolic link:

https://www.ibm.com/support/knowledgecenter/SSGSG7_7.1.8/client/t_cfg_ssl_symb_lnk_gskit.html

Cause

Incompatibility of the newer GSKIt version that comes with the new 7.1.8/8.1.2.+ Backup-Archive Client and the older GSKit version that exists with DB2 9.7.

Diagnosing The Problem

A Spectrum Protect API trace (service) shows the following error :

<timestamp> [xxx] [nn] : gskit.cpp (2041): GSKit::CreateEnvHandle(): GSKit version: 8.0.50.47

This shows that DB2 is still using an old GSKit version (8.0.50.47) despite the changes to the symbolic links.

Subsequent trace entries show errors when trying to open the password or certificate db, i.e,


<timestamp> [xxx] [nn] : gskkmlib.cpp ( 853): GSKKMlib::gskkmImportKeys Import keys failed. Reason(GSKKM_ERR_DATABASE_INVALID_FILE_TYPE) - rc(17)
...
<timestamp> [xxx] [nn] : GSKitPasswordFile.cpp( 952): GSKitPasswordFile::readPassword: GSKKM_OpenKeyDb failed with error 17
<timestamp> [xxx] [nn] : GSKitPasswordFile.cpp( 961): GSKitPasswordFile::readPassword: returning 168

Resolving The Problem

DB2 9.7 reached End Of Support in September 2017. Customers who have obtained an Extended Support Contract for DB2 9.7 can contact DB2 Support to obtain a newer GSKit version for DB2 9.7.

Customers who do not have an Extended Support Contract should use an IBM Spectrum Protect API client version lower than 7.1.8/8.1.2 with their DB2 version 9.7 instances. Upgrading to DB2 10.5 or higher would be a preferable alternative to using a lower-level IBM Spectrum Protect API client version, so that the methods documented in the links below can be utilized in the environment. For DB2 versions higher than 9.7, the procedure documented in these URLs, to change the symbolic link to point to the newer GSKit package, works successfully. However, this does not work in DB2 9.7.

[{"Product":{"code":"SSEQVQ","label":"IBM Spectrum Protect"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.1.2;8.1.3;7.1.8;8.1.4","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg22013932