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[Db2] ロールフォワードが終わらない場合の対処方法

Question & Answer


Question

ロールフォワード処理に通常より時間がかかってしまっています。 リカバリー時間短縮のための方法を教えてください。

Cause

ロールフォワードは、データベース・ログ・ファイルに記録された変更を適用することによって、リストアされたデータベースまたは表スペースのデータを更新する処理です。
すべてのログ・ファイルを適用した後 (フォワード・リカバリー)、コミットされていないトランザクションをすべてロールバックします (バックワード・リカバリー)。 これによりバックアップ・コマンドを実行した後に生成されたトランザクションをリカバリーします。

Answer

ロールフォワードの所要時間は、ログに記載されたトランザクション内容にも依存するため、短縮する方法はなく、完了を待つほかありません。

■ ロールフォワードの進捗状況をモニターする方法

ロールフォワードの進行状況は、db2pd -recovery オプション、または LIST UTILITIES SHOW DETAIL コマンドでモニターできます。
  1. (UNIX および Linux) インスタンス・オーナーとしてログインします。
    (Windows) Administrator としてログオンし、 DB2 コマンド・ウィンドウを開きます。
  2. 以下のコマンドを実行します。

    db2pd -db <データベース名> -recovery
    または
    db2 list utilities show detail


コマンド出力例など詳細は以下マニュアルページを参照ください。
ロールフォワード操作のモニター


運用上の考慮点
  • データベースおよび表スペース・ロールフォワード操作は、オフラインで実行されます。 ロールフォワード操作が正常に完了するまで、データベースは使用できません。
  • SYSCATSPACE が含まれていない限り、 オンラインで表スペースのロールフォワード操作を実行できます。表スペースに対してオンラインでロールフォワード操作を実行するとき、 その表スペース自体は使用できませんが、 データベース内の他の表スペースは使用できます。


関連情報
パスポート・アドバンテージによく寄せられる質問
db2pd DB2 データベースのモニターおよびトラブルシューティング・コマンド -recovery パラメーター
LIST UTILITIES コマンド

お問合せ先
技術的な内容に関して、パスポート・アドバンテージの契約のもと Db2 テクニカル・サポートへお問い合わせください。
Db2 テクニカル・サポート

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Document Information

Modified date:
21 August 2023

UID

swg22013613