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[Db2] クラッシュ・リカバリーが終わらない場合の対処方法

Question & Answer


Question

Db2 インスタンスが異常終了した後、自動的にクラッシュ・リカバリーが開始されましたが、終了しません。 復旧を急いでいるのでクラッシュ・リカバリーを停止する方法を教えてください。

Cause

クラッシュ・リカバリーは異常終了後のデータベースを正常な状態に戻すために必要な処理です。
更新処理中に異常終了となった場合は、次回起動後のデータベース再始動の際にクラッシュ・リカバリーが行われ、未コミット・トランザクションのロールバックなどが行われます。

Answer

クラッシュ・リカバリーは途中で停止することはできず、完了するのを待つほかありません。

■ クラッシュ・リカバリーの進捗状況をモニターする方法

クラッシュ・リカバリーの進行状況は、db2pd の -recovery オプション、 または、LIST UTILITIES SHOW DETAIL コマンドでモニターできます。

  1. (UNIX および Linux) インスタンス・オーナーとしてログインします。
    (Windows) Administrator としてログオンし、 DB2 コマンド・ウィンドウを開きます。
  2. 以下のコマンドを実行します。

    db2pd -db <データベース名> -recovery
    または
    db2 list utilities show detail

    コマンドの詳細は以下マニュアル・ページを参照してください。
    db2pd DB2 データベースのモニターおよびトラブルシューティング・コマンド -recovery パラメーター
    LIST UTILITIES コマンド

    ■ クラッシュ・リカバリーの完了を確認する方法

    クラッシュ・リカバリーが正常に完了すると管理通知ログに以下のような ADM1531I メッセージが記録されます。
    [DB2 LUW] db2diag.log や管理通知ログの出力先 (IM-10-0AC)
    2018-01-16-02.41.22.017490   Instance:db2inst1   Node:000
    PID:20932(db2agent (SAMPLE 0)   TID:3196053248
    Appid:9.169.0.1.42268.180116004727
    recovery manager  sqlpresr Probe:3100   Database:SAMPLE

    ADM1531I クラッシュ・リカバリーが正常に完了しました。


    運用上の考慮点


    関連情報
    パスポート・アドバンテージによく寄せられる質問
    クラッシュ・リカバリー

    お問合せ先
    技術的な内容に関して、サービス契約のもと IBM サービス・ラインにお問い合わせください。
    IBM サービス・ライン

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    Document Information

    Modified date:
    16 June 2018

    UID

    swg22013498