Troubleshooting
Problem
Your database server is listening for connections to the database on a virtual IP which is different than the host physical IP address. You configured a Vulnerability Test for CAS (Change Audit System) on that database in IBM Infosphere Guardium. You run the Test and it fails, it can not connect to the Datasource.
Symptom
Vulnerability Test fails with a connectivity error indicating it was unable to connect to the database. Error string may vary as it depends on the database system but error will indicate the inability to open the database connection.
Cause
Guardium is trying to open the connection to the database connecting to the physical ip of the host but the database connections in this host use a different ip address.
Resolving The Problem
Specify the Custom URL field for the Datasource used in the Vulnerability Test to be the jdbc url to connect to the database using the database ip address (the virtual ip).
The Datasource configuration will be:
Host config : use the host physical ip address
Custom URL: Update this field with the jdbc connection url to connect to the
Database, using the virtual ip address (where database listens on)
to reference the database server.
Steps:
1.- login as 'admin' to the collector's GUI
2.- Navigate to Tools / Datasource Definitions
3.- Select the appropriate Application type you created the Datasource under
4.- Highlight the datasource
5.- Modify
6.- Set the "Custom URL" field to the jdbc connection url to your server using the "virtual" ip address or hostname the database listens on , for example:
jdbc:sqlserver://<virtual ip for database connections>:1433;databaseName=<dbname>
where:
<virtual ip for database connections> is the virtual ip applications use to connect to the database
<dbname> is the name of your database
7.- Click on "Test Connection" to test the connection
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Document Information
Modified date:
16 June 2018
UID
swg21676374