IBM Support

Data Server Manager (DSM) shows "Invalid Credentials" status for a monitored database

Troubleshooting


Problem

Data Server Manager (DSM) shows "Invalid Credentials" status for a monitored database.

Symptom

Data Server Manager (DSM) shows "Invalid Credentials" status for a monitored database and stops collecting performance data.

Cause

DSM turns on the Invalid Credentials internal flag, when while connecting to the monitored database, DB2 returns -4214 error.
To avoid the user account to be lockout from the operating system, DSM turns on the Invalid Credentials internal flag and stop trying to connect to the monitored database, until the Invalid Credentials flag is turned off.
Common scenarios for this issue:
- userid/password is invalid
- The password is expired
- LDAP server is down
- LDAP server has a delay to authenticate the userid/password

Diagnosing The Problem

The dsserver.log file shows the following error message:

Credentials for <monitored_database_name> were earlier found to be invalid. Did not attempt to re-connect to avoid user account lockout

Resolving The Problem

Turn off the internal DSM Invalid Credential flag:
- Edit the database configuration, and change the userid/password to a wrong userid/password. Click OK to save the configuration.
- Edit the database configuration again, and change to the correct userid/password. Click on Test Connection, and click OK to save the configuration.
That would reset the internal flag, and DSM should be able to connect to the database again.

Another option is to use the upddbcredential script under <DSM_install>/dsutil/bin directory. The instructions on how to use the script is available in the README.txt file, located under the same <DSM_install>/dsutil/bin directory



If you are using DSM V2.1, the new property DS_DBCONN_TRACE has been added to capture additional tracing information to help you investigate the root cause of the problem.
If you add this property in the dswebserver.properties file and set to true, for example:
DS_DBCONN_TRACE=true
the debug statement will show up in <DSM install>/logs/dsserver.0.log file.
Restart DSM after the change.
Write down the time that you turned on the property,  and the time that you start to see the Invalid Credential error messages.

When you see the Invalid Credential problem, search for the following string in the dsserver.0.log file:
   
    --- Database Connection failed for DB Profile =
   
The string will tell you which profile connection failed, what is the error code, and if it is an invalid credential issue, then it displays the userid and password.
If you don't want the userid/password information explicit in the log files, make sure that you remove the property from dswebserver.properties file, remove the old log files, and restart DSM.

This property won't fix anything.  It will just allow DSM to write additional info in the dsserver.0.log file, so you can investigate why DSM keeps getting the Invalid Credential error.

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Document Information

Modified date:
16 June 2018

UID

swg21984623