IBM Support

Data is not displayed in custom fields for Mobile Mobile

Troubleshooting


Problem

When using the Mobile Mobile Configuration Tool to add a field the data from Maximo is not displayed.

Symptom

The field shows correctly within the application however the data coming from Maximo does not show.

Cause

This can be caused by defining your attributes in the XML on your field in uppercase. Even if the attribute is defined in Maximo in uppercase it will be sent in lowercase.

Resolving The Problem

To resolve this issue update your field mapping to use lowercase for your attribute, for example if your field is defined as.

<field hide-label="true" id="testbg7a9" value="{woDetailResource.item.UPPERCASE}" wrap="true"/>

Change it to the following and save.

<field hide-label="true" id="testbg7a9" value="{woDetailResource.item.lowercase}" wrap="true"/>

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000hAgaAAE","label":"Maximo Application Suite->MAS Applications->Mobile"}],"ARM Case Number":"TS006878803","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
25 October 2021

UID

ibm16495927