Troubleshooting
Problem
Attempts to run Data Extract agent fails to extract the corresponding YFS_ORDER_HEADER record for the orderline in IBM Order Management on Cloud.
Symptom
When Data Extract agent is run, it exports the records from multiple tables like YFS_ORDER_HEADER and YFS_ORDER_LINE tables. Sometimes it is observed that Data Extract Output has the records from YFS_ORDER_LINE table but corresponding YFS_ORDER_HEADER record is missing.
Cause
Data extract does not consider Parent-Child table/relationship between YFS_ORDER_HEADER and YFS_ORDER_LINE records.
Diagnosing The Problem
Extract is based only on modifyts of DB table records. When data extract is run for a table, it only checks for modifyts of that particular table.
Resolving The Problem
Every time Data Extract Agent runs (after the first run), the extract agent considers the start time as the end time from when the extract tool last run for the query. The end time is calculated as the current time – 1 hour. Now the records are extracted based on the 'Modifyts', If a particular record falls between start time and end time then only it is extracted.
For example:
There is an order with multiple orderlines, Now if one line is updated, then modifyts of that line and order header gets updated. Now if the new value of modifyts for these records falls after the end time of Data Extract Agent run time then that line and order header record will not be extracted. This is as per product design.
Related Information
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Document Information
Modified date:
01 November 2021
UID
swg22011744