IBM Support

CWSOM1017E: Unable to access log file (file store location) while starting Messaging Engine

Troubleshooting


Problem

WebSphere Application Server (WAS) Messaging Engine fails to start. The following errors occurred in the SystemOut.log file: CWSIS0002E: The messaging engine encountered an exception while starting. Exception: com.ibm.ws.sib.msgstore.PersistenceException: Unexpected exception caught starting persistent message store: CWSOM1017E:ObjectManagerState=ObjectManagerState( < Log file path> )/Stopped ManagedObject(0/0)/Ready/(ObjectManagerState) caught exception= (Exception) trying to locate or create log file name={2}(String). CWSID0035E: Messaging engine cannot be started; detected error reported during com.ibm.ws.sib.msgstore.impl.MessageStoreImpl start() CWSID0027E:Messaging engine cannot be restarted because a serious error has been reported.

Cause

These messages indicate a Messaging Engine is not able to access file system locations used by file store.

Possible causes are:

1) Incorrect path. File store locations provided do not exist.

2) User account is not authorized to read or write to the file system. The user account under which WebSphere Application Server runs or the userID which is trying to start the Messaging Engine is not authorized to read and write to the file system location (Log file system location).

3) Some times NFS version 3 file system may create this type of problem because of its locking issues. NFS3 file system has some locking issues and we suggest to use NFS4 if you see any locking related issues.

NFSv4 is recommended for use with highly available filestores because the NFSv4 specification includes lease-based locking. This ensures that all implementations of NFSv4 have a locking strategy
that allows the file server to detect the failure of an application that owns a lock, and releases that lock in a timely fashion for other applications to obtain.

Resolving The Problem

Please make sure that the file store log file exists and it is accessible by the specified userID.

To further narrow the appropriate action, check the application server FFDC log for an exception that matches the message seen in SystemOut.log like below :

a) java.io.FileNotFoundException: path (system cannot find the path (file store log file location) specified).
If you see this type of exception indicating the system could not find the path, note the path and check whether this path exists or not.

b) java.io.FileNotFoundException: path (Access is denied). In this case you see this exception either in SystemOut.log or in the ffdc's:

    CWSOM1017E: ObjectManagerState=ObjectManagerState(<file store path>)/Stopped ManagedObject(0/0)/Ready/<some ID>(ObjectManagerState) caught exception=java.io.FileNotFoundException: (<file store path>)(Access is denied.)(Exception) trying to locate or create log file name=<file store path>\Log(String).
If you see this type of exception indicating access was denied, give access to the User account that was not authorized.

c) If you are using a NFS file system please also make sure that you are using NFS4 to avoid any locking related issues on the file store.

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Product Synonym

WebSphere Application Server WAS SIB SIBUS SI BUS

Document Information

Modified date:
15 June 2018

UID

swg21609458