IBM Support

CWBCO1047 on any function that uses database host server

Troubleshooting


Problem

CWBCO1047 on any function that uses the database host server (QZDASOINIT or QZDASSINIT).

Symptom

CWBCO1047 on any function that uses the database host server (Data Transfer, ODBC, JDBC, etc.).

A communications trace on the IBM i-side shows the IBM i sending a FIN after the Start Server, Start Server Reply, Set Attributes sequence at the start of the database host server conversation. A CWBCOTRC on the client side shows CWBCO1047 rc8405.

No QZDASOINIT joblog is produced, even with 4 00 *SECLVL logging level.

Cause

Database host server access is blocked by Application Administration setting for 'Toolbox Application Server Access' (under 'Host Applications' tab, 'IBM i', 'Database'). This setting corresponds to Function ID 'QIBM_DB_ZDA' in WRKFCNUSG.

An Application Administration blockage typically results in a more meaningful error on the client end (such as CWBAD1003 "... Application Administration settings prevent [function] from running..."). That is not the case in this situation.

Environment

All IBM i OS releases V6R1 and higher

Diagnosing The Problem

See the output of DSPFCNUSG OUTPUT(*PRINT) for fastest resolution; check the settings for Function ID 'QIBM_DB_ZDA'. Alternatively, check the setting for 'Toolbox Application Server Access' in Application Administration in Navigator.

Resolving The Problem

Change the settings for Function ID 'QIBM_DB_ZDA' using WRKFCNUSG, option 2 (CHGFCNUSG) accordingly for the user(s). Alternatively, use Application Administration in Navigator to make the change.

[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.1.0"}]

Document Information

Modified date:
18 December 2019

UID

nas8N1022532