IBM Support

Customers upgrading to Information Server 11.7.1 Fix Packs get credential mapping errors from their DataStage clients

Troubleshooting


Problem

Customers upgrading existing Information Server Windows versions 11.7.1.0 or 11.7.1.1 systems to Fix Pack 3 or later fix packs can get credential-mapping errors from their DataStage clients for suite logon usernames that previously worked correctly.

Symptom

The typical error from the Windows clients such as Designer, Director, and Administrator client is "No Engine credentials were found on the Services Tier for the specified user ... on Information Server Engine". 

The dsjob and dsadmin command-line tools give the error message "Engine tier login username or password is incorrect. Check credential mapping is set up correctly, if used".

Cause

The updates in the fix packs need the MSVCR120.DLL that is included in newer versions of the JDK.

Diagnosing The Problem

Navigate to the \IBM\InformationServer\jdk32\jre\bin directory on the client machine. If there is no MSVCR120.DLL in that directory, then the JDK needs to be updated. You can run java -version in that directory to display your Java™ version. As an example, if the Java™ version on your system is "1.8.0_151", the JDK needs to be updated.

Resolving The Problem

Locate and download the latest recommended Java™ for Information Server by searching for "Information Server JVM" on Fix Central. Install on your client, services, and engine tier systems. Where installed on Windows, both the 32-bit and 64-bit versions must both be installed. 

Document Location

Worldwide

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Document Information

Modified date:
25 October 2022

UID

ibm16552878