Troubleshooting
Problem
When running the report and generating CSV output, the file is saved without an extension.
Symptom
Generating CSV output opens a download dialog box with no option to select the file type to save as.
Cause
The RSVP.CSV.MIMETYPE parameter for ReportService and BatchReportService is not configured properly or has a typo.
Resolving The Problem
- Launch, IBM Cognos Administration.
- On the Status tab, click System.
- In the the Scorecard pane, click the arrow to view the Change view menu. Click Services, and then click All.
- Click the arrow next to ReportService to display the Actions menu, and then click Set properties.
- Click the Settings tab.
- Click Edit next to Advanced Settings.
- Select Override the settings acquired from the parent entry.
- In the Parameter column, enter: RSVP.CSV.MIMETYPE
- In the Value column, make sure the value is: applicaton/csv.
- Click OK twice.
- Redo steps 5 - 11 for the BatchReportService.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
23 September 2022
UID
ibm16823161