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Creating return orders in Well call center 9.3 updates charge transaction record against return order and not sales order

Troubleshooting


Problem

Attempts to create return order in IBM Well Call Center (WCC) 9.3 updates charge transaction record against return order and not sales order.

Symptom

Steps to reproduce:
  1. Create a Sales order. Ship and invoice the order.

     
  2. Login to WCC and search for the sales order.

     
  3. Now create a return order for this Sales order.

     
  4. Invoice the Return order.
The charge transaction record is updated against the Return order. The charge transaction record for the return order is not inserted against the Sales order and acts like a blind return.

Cause

This is working as designed in Web call center 9.3

Resolving The Problem

This change is intended to help the use of Web Call Center for POS. From a POS perspective, the terminal orders are considered complete at sale. The current behavior of WCC is intended to enable the refunds to be treated as a separate transaction.

You can still have returns recorded against the sales order by using the following work around:
Extend the createrOrder Screen in WCC and pass the following attributes at order level:
ProcessPaymentOnReturnOrder="N"
ReturnByGiftRecipient="N"

Please refer the documentation for more information on how the screens can be extended

https://www.ibm.com/docs/en/order-management-sw/9.2.1?topic=implementing-extending-customizing-application

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Document Information

Modified date:
10 May 2021

UID

swg21674866