IBM Support

Creating new resourceId for controlling access to custom screens in Call Center For Commerce

Question & Answer


Question

How do you create and define a new Resource under ISCCSSYS001 / ISC_FEATURE for controlling access to a custom screen in IBM Call Center for Commerce ?

Cause

You want to restructure access levels for users

Answer

Steps to resolve:

  1. Set the below property in customer_overrides and rebuild resources.jar
    > yfs.enable.resource.addition=Y

  2. Create a custom resource under Application Platform > Presentation > Resources > Sterling Call Center.
    The plus button would now be enabled. Add this new resource under ISCCSSYS001 / ISC_FEATURE by selecting ResourceType as Features and Application as isc.

  3. Create a new user and assign him a user group. Grant/revoke permission to this user group on this newly created resource under Application Platform > Security > Groups > [user_group] > IBM Call Center For Commerce > Resource Hierarchy > Applications > IBM Call Center For Commerce > Call Center Features > [your custom resource]

  4. Use this new resourceId in to control entities in call center screens using the below code -
     _scResourcePermissionUtils.hasPermission("ISCCSCUST0001")

    where _scResourcePermissionUtils refers to "scbase/loader!sc/plat/dojo/utils/ResourcePermissionUtils" package

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Sterling Call Center","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF014","label":"iOS"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.3;9.4;9.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22006744