IBM Support

Controller Web does not fully logout authenticated users unless web browser is closed (using CAM authentication)

Troubleshooting


Problem

User launches web browser, and navigates to Controller Web site (http ://servername:9080/fcm.web/login). User is prompted to log onto Controller Web using a Cognos CAM authentication box. When inside the Controller Web application, user then clicks 'logout'. However, the user does not close their browser. User then navigates to the Controller Web site and tries to re-enter Controller Web. User expects to be prompted for their username/password, but they do not get challenged. - Instead, user gets automatically logged back into Controller Web.

Symptom

The first time that they launch Controller Web, they are prompted to authenticate to the Cognos namespace:

However, after clicking Logout...




...user then relaunches Controller Web. This time they do not get prompted to logon to their Cognos CAM namespace.

Cause

There are two causes for this problem:

  • Scenario #1 - Limitation of Controller 10.3.0
    • This does not support logoutMode.logoutCam

  • Scenario #2 - Customer has not enabled logoutMode.logoutCam
    • The default setting has this disabled (false) which means that when a user logs out from Controller web, they will not be logged off from BI also.

Environment

Controller configured to use Cognos CAM authentication.

  • The problem does not affect 'Native' authentication.

Resolving The Problem

Fix:

Ensure that you are using Controller 10.3.1 (or later) and enable the setting: logoutMode.logoutCam

  • This causes the user to be logged off (from Cognos BI CAM) when the user chooses to log off from Controller Web

Steps:

1. Logon to the Controller application server

2. Browse to the 'fcm.web' folder

  • TIP: By default, this is here: C:\Program Files\IBM\cognos\ccr_64\fcmweb\wlp\usr\servers\fcm.web

3. Open the following file (inside notepad.exe): com.ibm.cognos.fcm.web.properties

4. Add the following line:

    logoutMode.logoutCam=true

5. Save changes
6. Restart Windows service 'IBM Cognos Controller Web'
7. Test.

Workaround:

Ensure that users close their web browser after clicking 'Logout'.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.3;10.3.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22009873