IBM Support

Controller logon Window does not appear, or "The webpage cannot be found" appears (after selecting Database) caused by incorrect Report Server settings

Troubleshooting


Problem

User launches Controller client. User is prompted with a choice of databases. User selects the database.
Afterwards, user expects the login window to appear.
  • However, it does not.
Depending on the environment, the user may see slightly different symptoms.

Symptom

The exact symptoms will vary, depending on the environment:
  • Scenario #1 - After choosing the detabase, the Controller Client the screen disappears completely.
  • Scenario #2 - After choosing the detabase, the following error message appears (inside a small Internet Explorer window/box):
image-20190719115827-1
The webpage cannot be found
 HTTP 404  

   Most likely causes:
There might be a typing error in the address.
If you clicked on a link, it may be out of date.
   What you can try:
     Retype the address. 
     Go back to the previous page.
     Go to  and look for the information you want.  

Cause

There are several reasons why the Controller client does not launch after choosing the database.
  • For more examples, see separate IBM Technote #1346783.

This IBM Technote specifically deals with the scenario where the 'Report Server' settings (configured inside "Controller Configuration" on the application server) are invalid.
More Information:
Each end user's client device must be able to connect to the report server for authentication purposes, during logon. Without this ability, the Controller client cannot proceed.

The server names used in "Controller Configuration" must be resolvable by the end user's client device. There are two types of servername:
  1. NetBIOS (e.g. SERVERNAME)
  2. FQDN (e.g. servername.COMPANY.COM)
Ask your I.T. department for more information on which type of name is the most suitable for your environment.
 
Example #1
In many cases, the problem is caused by the administrator configuring the setting to use NetBIOS names...
image-20190719120737-2

...and is solved by changing these to their FQDN equivalents, for example:
image-20190719120823-3
Example #2
In a different real-life customer example, they were using Cognos Analytics, but they mistakenly used the old Cognos BI settings:
http://my-ca-server.company.com/ibmcognos/cgi-bin/cognosisapi.dll

Diagnosing The Problem

Depending on the environment, you may find that *some* client devices can successfully launch Controller, while others fail.
Example #1
You typically find that the Controller client successfully launches when run directly on the Controller application server itself.

Resolving The Problem

Ensure that the "Report Server" settings inside "Controller Configuration" are correctly configured.
For example:
  • Do not use 'localhost'
  • Make sure they can be resolved (for example via DNS) by the end user's PC to the correct TCP/IP address.

Steps:

1. Logon to the Controller application server as an administrator
2. From the Start menu, launch "Controller Configuration"
3. Open section "Web Services Server"
4. Open subsection "Report Server"
5. Ensure that the setting for "Report Server" is correct, and can be resolved by the end user's PC.
Example (when using Cognos Analytics without SSO):
http://my-ca-server.company.com:9300/bi/v1/disp
image-20190719121355-4
Example (when using Cognos Analytics with SSO):
http://my-ca-server.company.com/ibmcognos/bi/v1/disp
Example (when using Cognos BI):
http://biserver.companyname.com/ibmcognos/cgi-bin/cognos.cgi
   
6. Click "Save"
7. Test.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
19 July 2019

UID

swg21449887