Troubleshooting
Problem
User launches Controller client (ccr.exe). User is prompted with database selection, and chooses relevant database.
Afterwards, however, instead of being prompted to logon (or to choose the period) the users client session disappears.
- There is no error message.
Symptom
Controller client crashes/ends/disappears during logon process. There is no message recorded either:
- on screen
- or inside the Event Viewer.
Cause
There are many different potential causes for similar behaviour/symptoms.
This Technote specifically relates to the scenario where the cause is that "Cognos Configuration" is configured incorrectly.
- TIP: For more examples, see separate IBM Technote #374171.
This Technote specifically relates to the scenario where the cause is that "Cognos Configuration" is configured incorrectly.
- Specifically, the customer had configured "Restrict access to members of the built-in namespace" to be set to "False":
Environment
Controller configured to use (Cognos) CAM Authentication:
Resolving The Problem
Inside "Cognos Configuration", change "Restrict access to members of the built-in namespace" to be set to "True":
- TIP: For more information see separate IBM Technote #1380097.
Steps:
- Logon to Report Server (Cognos Analytics server) as an administrator
- From the Start Menu, launch "Cognos Configuration"
- Expand section "Local Configuration - Security - Authentication"
- Ensure that the setting "Restrict access to members of the built-in namespace" is set to "True"
- After making changes, restart the Cognos service (for example restart the 'IBM Cognos' Windows service).
Related Information
Document Location
Worldwide
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Document Information
Modified date:
10 March 2020
UID
ibm15694639