Troubleshooting
Problem
Control Center will no longer start
Symptom
Engine logs show the following errors
Info: CC->log4j.LogFactory.defaultConfiguration()..BasicConfigurator.configure()... Unable to get JDBCService to initialize SCCConnectionManager... An error occurred while starting the engine ... java.lang.RuntimeException: Unable to get JDBCService to initialize SCCConnectionManager... java.lang.RuntimeException: Unable to get JDBCService to initialize SCCConnectionManager...
Cause
Earlier someone started Control Center as root instead of the normal user.
This cause directories and files to be incorrectly secured to root.
files owner/groups were found showing as root:root
Diagnosing The Problem
Check the Engine logs, and the Control Center directories.
Resolving The Problem
Set the files and directories back to the default Control Center user.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9GLA","label":"IBM Control Center"},"ARM Category":[{"code":"a8m0z000000cwVyAAI","label":"ENGINE"}],"ARM Case Number":"TS009915353","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"}],"Version":"All Versions"}]
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Document Information
Modified date:
19 July 2022
UID
ibm16605417