IBM Support

Content Manager startup takes long when the content store is in Oracle database

Troubleshooting


Problem

Content Manager startup takes long when the content store is in Oracle database

Cause

Network connection between the Cognos Content Manager server and Oracle database server is slow

Diagnosing The Problem

Review the cognosserver.log and search for the CM-SYS-2093 entry. If this issue is occurring, you will see that the Content Manager cache initialization is taking an excessive amount of time.
CM-SYS-2093 The Content Manager cache initialization is complete. 34372837 objects loaded in 5638.21 seconds.

Resolving The Problem


Add the following configuration entry in the ..\bin64\bootstrap_wlp_<osversion>.xml file:
 
-DcmcacheFetchSize=xxxx
Example (if using IBM JRE):
       
<param condName="${java_vendor}" condValue="IBM">-DcmcacheFetchSize=5000</param>
Example (if using Oracle JRE):
 
<param condName="${java_vendor}" condValue="Oracle">-DcmcacheFetchSize=5000</param>

The default value for this parameter is 1000 .  A Cognos Analytics restart is necessary after making the change.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0.7 and later","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 September 2023

UID

ibm10884730