Troubleshooting
Problem
During startup of WebSphere® Application Server, the below errors might occur when the message listener ports attempt to start.
Symptom
The following errors might appear at startup:
WMSG0019E: Unable to start MDB Listener Admin, JMSDestination jms/qcf : javax.jms.JMSException: Failed to create queue connection
J2CA0045E: Connection not available while invoking method queueRequest for resource jms/qcf.
J2CA0020E: The Connection Pool Manager could not allocate a Managed Connection: com.ibm.websphere.ce.j2c.ConnectionWaitTimeoutException: Connection not available
Cause
Each listener port that is configured on the Application Server requires one connection in the Queue Connection Factory (QCF) connection pool.
This problem occurs if multiple listener ports are configured with the same QCF, and the Maximum Connection Pool Size for the QCF is less than the number of listener ports associated with it.
For example, if there are 15 listener ports associated with a QCF and the Maximum Connection Pool Size for the QCF is 10, the first 10 listener ports start successfully, but the last five listener ports fail to start. This is because all 10 connections in the pool are in use.
The ConnectionWaitTimeoutException is issued.
Resolving The Problem
Ensure that the Maximum Connection Pool Size for the QCF exceeds the total number of listener ports that are associated with it. That way, there are enough connections in the pool to allow all of the listener ports to start successfully.
For help with the configuration, please see: Connection Factory Settings.
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Document Information
Modified date:
15 June 2018
UID
swg21198681