IBM Support

Connect to catalog in Oracle: ORA-12545: Connect failed because target host or object does not exist

Troubleshooting


Problem

A Data Manager catalog is held in an Oracle database. Attempting to connect to the catalog fails with an error.

Symptom

1. ERROR
DS-DBMS-E402: UDA driver reported the following:

UDA-SQL-0031 Unable to access the 'ALIAS_03E43FD8' database.

UDA-SQL-0532 Data Source is not accessible: 'TNS:MYORCL'.

ORA-12545: Connect failed because target host or object does not exist

Cause

The NAMES.DIRECTORY_PATH= option in the sqlnet.ora file contained an entry for EZCONNECT:-

NAMES.DIRECTORY_PATH= (TNSNAMES, EZCONNECT)

Usually, this entry only contains

NAMES.DIRECTORY_PATH= (TNSNAMES)

With easy connect it is possible to connect to a database using the following information:
server_name:port/service_name.

This means that Oracle now sees "TNS:MYORCL" as server_name and service_name "TNS" and port "MYORCL".

Resolving The Problem

Remove the EZCONNECT option in the NAMES.DIRECTORY_PATH= setting in the sqlnet.ora file.

Steps:

  • Open sqlnet.ora in a text editor
  • Search for NAMES.DIRECTORY_PATH=
  • Remove the EZCONNECT option

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU053","label":"Cloud \u0026 Data Platform"},"Component":"Data Manager","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.1;8.2","Edition":"","Line of Business":{"code":"","label":""}}]

Historical Number

1030720

Document Information

Modified date:
28 November 2022

UID

swg21370769