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Configuring NTP in PowerVM VIOS

Question & Answer


Question

How can I configure Network Time Protocol (NTP) in PowerVM Virtual I/O Server (VIOS)?

Cause

A synchronized time is important for error logging, Kerberos, and various monitoring tools.
It is also recommended for environments where the VIOS is part of a Shared Storage Pool (SSP) Cluster and Partition Mobility.
This document describes how to configure NTP on VIOS V3.1 to ensure consistent timing.

Answer

By default, the VIOS has an NTP client installed.
Note
If the VIOS is part of an SSP cluster, it is no longer required to stop the SSP node before changing the Time Of Day (TOD) or for setting up NTP, which can change TOD.  This applies to any currently supported VIOS releases. 
As of the time of this writing, fully supported VIOS releases include 3.1.1 and higher.  For more details, see PowerVM VIOS Lifecycle Information.

1. Login to the VIOS as padmin user.

2. To configure VIOS as NTP client, edit /home/padmin/config/ntp.conf and add your NTP server to the NTP configuration file.
$ vi config/ntp.conf
Add the line:  server <your_NTP_Server_FQDN>
For example, if your NTP Server is ntpserver.austin.ibm.com, your file should look something like this:
...
server ntpserver.austin.ibm.com
driftfile /home/padmin/config/ntp.drift
tracefile /home/padmin/config/ntp.trace
logfile /home/padmin/config/ntp.log
3.  Once NTP is configured, start the xntpd service:
$ startnetsvc xntpd
0513-059 The xntpd Subsystem has been started. Subsystem PID is xxx
To stop the daemon, run:
$ stopnetsvc xntpd

To check status of xntpd daemon, run:
$ lsnetsvc xntpd
    Subsystem         Group            PID          Status
     xntpd            tcpip            364568       active

 
After the daemon is started, your log in /home/padmin/config/ntp.log should look similar to the following example if the time synchronization is successful with the NTP server.
Successful ntp synchronization
6 Dec 09:48:55 xntpd[581870]: synchronized to 9.3.4.7, stratum=2
6 Dec 10:05:34 xntpd[581870]: time reset (step) 998.397993 s
6 Dec 10:05:34 xntpd[581870]: synchronisation lost
6 Dec 10:10:54 xntpd[581870]: synchronized to 9.3.4.7, stratum=2
If the log shows messages similar to the following, you have to set the time manually first.
Too large time error
$ cat config/ntp.log
5 Dec 13:52:26 xntpd[516180]: SRC stop issued.
5 Dec 13:52:26 xntpd[516180]: exiting.
5 Dec 13:56:57 xntpd[516188]: synchronized to 9.3.4.7, stratum=3
5 Dec 13:56:57 xntpd[516188]: time error 3637.530348 is way too large
      ( set clock manually)
To set the date on the VIOS, use chdate command.  For example, to change the date to Tuesday, December 5, 13:30:00 2017, you would run:
$ chdate 120513302017
Tue Dec  5 13:30:00 CDT 2017

[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSPHKW","label":"PowerVM Virtual I\/O Server"},"ARM Category":[{"code":"a8m50000000L0KwAAK","label":"PowerVM VIOS-\u003ENETWORK TIME PROTOCOL (NTP)"}],"ARM Case Number":"TS008846387","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
18 September 2023

UID

isg3T1012033