IBM Support

A configuration error might occur during the installation of the Application Client on an IBM i system

Troubleshooting


Problem

If you install the Application Client for IBM WebSphere Application Server Version 8.0 on an IBM i system, the configuration actions might not run and a warning might be generated in the installation log file, []/QIBM/UserData/InstallationManager/logs/[]timestamp[].xml[], that states "Configuration errors were detected during the installation." View the log files under the [][]app_client_root []/logs/postinstall[] directory to investigate the severity of the errors.

Cause

This is due to an ordering problem in the metadata.

Resolving The Problem

You can resolve this issue in one of the following two ways:

  • Install interim fix 8.0.0.0-WS-AppClient-i5OSPPC-IFPM39432.

    For information about installing interim fixes on Version 8.0.0.0, see Installing interim fixes for WebSphere Application Server Version 8.0.0.0 on IBM i operating systems.

    This runs the necessary configuration actions and configures your system correctly.

  • Perform the following actions.
    1. Copy the command from the log file; for example:

      <entry num='108' time='1305739283517' elapsed='35:40.01' level='WARNING' thread='Thread-6558'>
      <logger>global</logger>
      <class>com.ibm.ws.exec.command.Exec</class>
      <method>exec</method>
      <message>com.ibm.ws.exec.command.Exec
      Command:
      /QIBM/ProdData/WebSphere/AppClient/V8/bin/postinstall /QIBM/ProdData/WebSphere/AppClient/V8 -WS_CMT_CONF_DIR /QIBM/ProdData/WebSphere/AppClient/V8/properties/postinstall/ -MASTER_ACTION_REGISTRY /QIBM/ProdData/WebSphere/AppClient/V8/properties/postinstall/masterRegistry.xml -SUB_ACTION_REGISTRY /QIBM/ProdData/WebSphere/AppClient/V8/properties/postinstall/cacheRegistry.xml -WS_PI_ACTION_REGISTRY_EXTENSION /QIBM/ProdData/WebSphere/AppClient/V8/properties/postinstall/registryExtension.xml -WS_CMT_LOG_HOME /QIBM/ProdData/WebSphere/AppClient/V8/logs/postinstall/ -POSTINSTALL_LOG_FILE /QIBM/ProdData/WebSphere/AppClient/V8/logs/postinstall/postinstall.log -WAS_HOME /QIBM/ProdData/WebSphere/AppClient/V8 -USERDATA_LOC /home/vandepol/clt/profiles -LOCAL_HOST toras2fe.torolab.ibm.com -SERVER_HOST_NAME  -SERVER_PORT_NUMBER 
      Description : Running post install actions
      Return code : 1
      StdOut :  
      StdErr : .: 001-0023 Error found opening file /QIBM/ProdData/WebSphere/AppClient/V8/properties/os400.properties. No such path or directory.
      </message>
      </entry>

    2. Run the command manually from Qshell command line.
      This step runs the necessary configuration actions, which puts the system a valid state.


Optionally, you can install WebSphere Application Server Version 8 Fix Pack 1 to resolve this issue. For more information about this fix pack, see http://www14.software.ibm.com/webapp/wsbroker/redirect?version=matt&product=was-nd-mp&topic=wasv8001_readme1.

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Install","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"8.0","Edition":"Base;Express;Network Deployment","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21499593