Troubleshooting
Problem
Column analysis jobs remain in queue and are not processed after upgrading an existing Infosphere Information Server with WebSphere Liberty on a DB2 repository to version 11.7.1.1 SP2.
Symptom
Column analysis stays in state "In queue" forever. The WebSphere log shows that the analysis was submitted, and the ODFAdmin tool shows that the job was submitted too, but the analysis never starts.
Cause
The latest DB2 JDBC driver requires two additional mandatory parameters that are not present in the IADB configuration file of the upgraded machine.
Environment
All operating systems, InfoSphere Information Server with WebSphere Liberty on a DB2 repository, upgraded to version 11.7.1.1 SP2.
Resolving The Problem
On the system where WebSphere Liberty is installed, please navigate to <InformationServer_Install_Location>/IBM/InformationServer/wlp/usr/ servers/iis/iadb.dataSources.xml and look at the entry for properties.db2.jcc. You should see the following:
<properties.db2.jcc databaseName="${ia.db.name}" portNumber="${ia.db.port}" driverType="4"
serverName="${ia.db.hostname}" password="${ia.db.password}" user="${ia.db.username}" />
Add the two parameters at the end of the element :
<properties.db2.jcc databaseName="${ia.db.name}" portNumber="${ia.db.port}" driverType="4"
serverName="${ia.db.hostname}" password="${ia.db.password}" user="${ia.db.username}" useJDBC4DataType="2" useJDBC4ColumnNameAndLabelSemantics="2" />
Document Location
Worldwide
[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSZJPZ","label":"IBM InfoSphere Information Server"},"ARM Category":[{"code":"a8m0z000000GnEDAA0","label":"DB2"},{"code":"a8m3p000000hAtUAAU","label":"WebSphere Application Server->WebSphere Configuration->WAS Liberty"}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.7.1","Type":"MASTER"}]
Was this topic helpful?
Document Information
Modified date:
28 June 2021
UID
ibm16465861