IBM Support

Cognos is Slow when Navigating Through the UI on a Remote Client Machine

Troubleshooting


Problem

When navigating through the UI, it takes about 3 to 4 seconds to open folders, click items and select objects using a browser on a remote client machine. When running via a browser on the Cognos server machine, it is much faster.

Cause

A VPN is being used on the remote client machine and is not installed on and not on the Cognos server. This is routing traffic and as a result, this is slowing Cognos down on the remote client machine.

Environment

User experiencing the error accesses Cognos via a VPN.

Diagnosing The Problem

A fiddler trace (or network trace) will show traffic directed to non-cognos sites when only using Cognos. You can see that timings for this request will take much longer than the Cognos requests, hence why Cognos will feel much slower.

Resolving The Problem

There are a few solutions to this issue regarding modifying the VPN:

  • See where the VPN is routing traffic to and see if this can be modified to somewhere closer to reduce latency.
  • Change or disable the VPN if possible.

 

Sometimes the issue in the UI only occurs when opening "Team content" (for example) for the first time and successive attempts after that are quicker as the this information is cached so enabling caching or temporary internet files may induce this effect as a slight work-around.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0.x","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
30 November 2018

UID

ibm10743027