IBM Support

Cognos "Invalid login response" when SSO Login rule is enabled

Troubleshooting


Problem

Invalid login response thrown when trying to access the login portal only when the SSO Login rule is enabled in IIS. With SSO disabled, user is brought to the login page without error. User has also followed the SSO document correctly (or used the script).

Cause

Incorrect configuration settings in IIS for the application pool. This vary depending on the setup of your server.

Environment

Cognos with a working Gateway component, trying to enable SSO (single sign on) via IIS.

Resolving The Problem

1. In IIS, locate your application pool you are using for the Cognos gateway.
2. Right-click the application pool and select advanced settings.
3. Under "Process Model", choose "Identity" and select the three dots to bring up the edit menu.
4. Then choose the correct type of built-in or custom account type. In one users case this issue was corrected by choosing the "Local System" type.

Related Information

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"SSO and IIS","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.1.x","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
21 March 2019

UID

ibm10876010