Troubleshooting
Problem
The Cognos Analytics Portal starts to become very slow to login after a period of time. Restarting the Cognos services solves the problem for a while and then the portal will become slow again.
Cause
The CAM-AAA ipf trace was enabled/active which caused the CAM_LPSvr process to consume large amount of memory.
Diagnosing The Problem
Check the Task Manager and look for CAM_LPSvr, check to see how much memory it is taking.
When services are restarted the process consumes ~1GB of memory. This consumption grows over a period of time till it reaches the bottleneck i.e available RAM and the portal stops responding.
Resolving The Problem
Steps to resolve the problem:
1. Disable the ipf trace.
- Go to the <cognos install dir>/configuration/ directory
- Look for a file of the name ipfclientconfig.xml
- Rename this file back to its original name i.e ipfaaaclientconfig.xml.sample
2. Stop the Cognos service in the right order.
On the Content Manager machine, let the CAM_LPSvr process exit.
If it does not exit then you can kill it.
3. Start the Cognos services.
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Document Information
Modified date:
15 June 2018
UID
swg22012408