IBM Support

Cognos Analytics login hangs using IIS web server

Troubleshooting


Problem

When logging in to Cognos Analytics using an IIS gateway, the login hangs.

The IIS logs show that the .css, .js, .svg, .woff, .ttf, and .json resources are being rejected with 404.7 errors. The 404.7 error usually means "The request filtering module is configured to deny the file extension". See here:

https://support.microsoft.com/en-ca/help/943891/the-http-status-code-in-iis-7-0-iis-7-5-and-iis-8-0

Cause

The 'Request Filtering Module' in IIS is configured to block certain file extensions.

Resolving The Problem

In IIS, click on your web site then go to Request Filtering -> File Name Extensions. Ensure that the follow extensions are NOT blocked:
.css
.js
.svg
.woff
.ttf
.json
Alternatively, explicitly Allow these extensions in Request Filtering.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
14 November 2019

UID

ibm11107141