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COGIPF_PARAMETERS missing in Audit database

Troubleshooting


Problem

Selected parameters during report execution can be added to the Audit database through the advanced setting RSVP.PARAMETERS.LOG. Usually this works fine, however for reports with huge parameter selections, the entries are not created in the Audit database.

Symptom

Missing rows in the COGIPF_PARAMETERS table in the Audit database.

Cause

Parameters selected sum up to an entry larger than ~65k, which exceeds the limit of UDP.

Environment

Cognos 10.2.1 FP10 or higher, 10.2.2 FP5 or higher, Cognos Analytics 11.x

Diagnosing The Problem

The COGIPF_PARAMETERS does not contain entries for reports with huge parameters selection.

Resolving The Problem

  1. In Cognos Configuration change the Audit database configuration from UDP to TCP.
  2. In case of SQL Server used as Audit database update to Cognos Analytics 11.0.5 or higher, as the JSQL driver for Microsoft SQL Server has been replaced with the Microsoft JDBC driver.

Related Information

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration and Configuration v11x","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22003902