Troubleshooting
Problem
When a user imports a new report from an older environment (especially Cognos 10.x) into a Cognos 11 environment, they are unable to edit the report in Report Authoring. This particular case has to do with a DB2 Content Store.
Symptom
Presented with CM-SYS-5192 error upon clicking the 'Edit Report' button from the ellipses.
Cause
The version of the Database and the driver do not correspond with each other. This is especially problematic if the driver is more than one version behind the database.
Diagnosing The Problem
Find the version of the IBM DB2 driver:
1. Launch a command line session or command prompt:
2. Change directory into the <cognos install>/drivers directory via the
command line.
3. Execute the following command: java -cp ./db2jcc.jar
com.ibm.db2.jcc.DB2Jcc -version
An example of the output is:
"/usr/cognos/analytics/ca11_0_5/drivers=>java -cp ./db2jcc.jar
com.ibm.db2.jcc.DB2Jcc -version
IBM DB2 JDBC Universal Driver Architecture 3.53.95"
The driver version in this case was 3.53.95, which was released with IBM DB2 9.5 FP4
Then find out the version of the DB2 database (refer to http://www-01.ibm.com/support/docview.wss?uid=swg21667518)
To see if the version of the driver and database correspond, refer to:
Refer to http://www-01.ibm.com/support/docview.wss?uid=swg21363866 for details on corresponding DB2 drivers and database versions.
Resolving The Problem
We need to ensure that the version of the driver is compatible with the database version. Although generally a driver that is one version behind the database should be working fine, there may be exceptions to this and it is best to simply have the corresponding driver for a particular version of the database.
Related Information
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Document Information
Modified date:
19 October 2018
UID
ibm10735891