IBM Support

"CM-SYS-5003 Content Manager ... is not configured to listen with TCP/IP" when starting Cognos BI service

Troubleshooting


Problem

Administrator tries to start the "IBM Cognos" Windows service (the Cognos BI Content Manager reporting service). An error appears.

Symptom

Error when starting service inside 'Cognos Configuration':
Error message from the starting windows of the service:
[Start einer JVM mit 'Maximaler Speicher in MB']
Eine Test-JVM mit der Speichereinstellung '768' wurde erfolgreich
gestartet. Beachten Sie, dass dies nicht gewährleistet, dass der IBM
Cognos-Service erfolgreich gestartet und ausgeführt werden kann.

[Service starten]
09:06:52, 'LogService', 'StartService', 'Success'.
09:06:53, CAF-WRN-0010 CAF input validation enabled.
09:06:53, CAF-WRN-0021 CAF Third Party XSS checking disabled.
09:06:57, CM-CFG-5063 A Content Manager configuration error was detected while connecting to the content store. CM-SYS-5003 Content Manager is unable to connect to the content store. Verify that the database connection properties in the configuration tool are correct and that when you test the connection, the test is successful. Cause: Failed Logon:com.jnetdirect.jsql.JSQLException: Instance [instancename] is not configured to listen with TCP/IP url:jdbc: JSQLConnect://servername\instancename/databasename/applicationName=IBM_C10_2_1_CM Stack trace: com.jnetdirect.jsql.JSQLException: Failed Logon:com. jnetdirect.jsql.JSQLException: Instance [instancename] is not configured to listen with TCP/IP url:jdbc:JSQLConnect:/servername\instancename/databasename/applicationName=IBM_C10_2_1_CM
at com.jnetdirect.jsql.JSQLDriver.connect(JSQLDriver.java:
302) at java.sql.DriverManager.getConnection
(DriverManager.java:571) at java.sql.DriverManager.
getConnection(DriverManager.java:215) at com.cognos.cm.
dbstore.CMDbStoreFactory.getJDBCConnection(CMDbStoreFactory.java:
1965) at com.cognos.cm.dbstore.CMDbStoreFactory.

Cause

Cognos Configuration has been configured to connect to the database server instance via its instance name, for example: servername\instancename

  • This is not compatible with all environments.

Specifically, the JDBC connection (used inside Cognos Configuration) cannot always resolve a SQL instance name to its correct TCP port.

Resolving The Problem

Modify the SQL server connection to use the following format: servername:TCPport

  • In other words, check which TCP port the SQL server is using (e.g. 1434) and enter this value into Cognos Configuration (instead of the instance name).

Steps:
1. Logon to the SQL server as an administrator
2. Launch SQL Server Configuration Manager (from the Start Menu)
3. Navigate to 'SQL Server Network Configuration'
4. Expand 'Protocols for <instancename>'
5. Right-click on 'TCP/IP' and choose 'properties':


6. Click tab 'IP Addresses'
7. Most servers will have several IP addresses
  • TIP: For most systems, the important setting is part of 'IPAll'

8. Check the values:


TIP:
  • For some customers, the value of 'TCP Dynamic Ports' is the value that needs to be used
  • For some users, the value inside 'TCP Port' is the value that needs to be used

9. Launch Cognos Configuration
10. Expand 'Content Manager' - 'Content Store'
11. Inside the section 'Database server and port' enter the value using the following format: servername:TCPport

12. Save changes
13. Restart service

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21994221