Troubleshooting
Problem
After removing a supported language within IBM Cognos Configuration, the error CM-REQ-2179 will be thrown when trying to modify objects within Cognos portal.
Symptom
The Locale "<code>" is not one of the configured content locales.
Cause
The content store has been initialised with a list of supported languages. Once you have initialised the content store you can no longer remove or add content locales in an existing content store. The process of adding or removing content locales must be done before the content store is created when the product is started for the first time.
Resolving The Problem
By doing a full content store deployment we can remove all unsupported locales, including those from the initial content objects. To perform a content store deployment, please follow the link in the Related Information section
Related Information
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m3p000000hBKzAAM","label":"Administration-\u003EDeployment"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
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Document Information
Modified date:
30 August 2023
UID
swg22010346