Troubleshooting
Problem
When a Cognos Analytics Administrator performs a consistency check, there are many entries with the following error:
"CM-ADM-4006 The object named 'USER' at first logon, created at the time 'TIME', of class 'account', with the search path 'CAMID("USER-CAMID")', no longer exists in the external authentication provider with the namespace name 'NAMESPACE'."
Cause
Cognos Analytics is detecting that a user profile still exists in the namespace setup in Cognos Configuration (which is stored in the content store), however this user does not exist in the external authentication provider.
Resolving The Problem
Perform a consistency check with the "Find and Fix" option to clear these entries and delete them from the content store.
NOTE: Create a full backup of the content store before using the "Find and Fix" option, as all inconsistent objects will be deleted.
Also ensure that the user profiles mentioned in the error entries do not have existing user objects in their My Content folder as these will be deleted in the Consistency Check process. Any objects that the user has in the team Content folder will show as "Owner: unknown" until a user with Set Policy permissions takes ownership of them.
Related Information
Document Location
Worldwide
[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl3zAAC","label":"Administration"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0.0;and future releases"}]
Was this topic helpful?
Document Information
Modified date:
05 November 2021
UID
ibm16402515