IBM Support

Client shows list of TM1 Servers but cannot connect to any of them

Troubleshooting


Problem

In TM1 Client Architect or Perspectives, in Server Explorer, the list of available TM1 Servers is displayed, but it is not possible to connect to any of them (whatever the value of IntegratedSecurityMode) : there is no error, just the hourglass and nothing happens, it hangs. In File / Options, the Admin Host name is correct and the command telnet 5498 is responding. Port 5498 has been allowed in firewall The PortNumber defined in tm1s.cfg has been allowed too. Architect installed locally on the server is able to connect.

Cause

Multiple Ethernet cards / IP Addresses

Resolving The Problem

- In a cmd.exe command window, run ipconfig to display all IP Addresses

- In Architect on the server, once connected to one TM1 Server, select it and take a look at the right side of Architect. Here appears an IP Address in the "Network Address" field.

- Now go to the client machine and try to run

telnet <Admin_Host_name> <Network_Address>

most probably this will give an error.

- That means the IPAddress parameter must be set in tm1s.cfg on the server, so that clients use the correct IP address.

- From the list displayed by the ipconfig command above, try to find which IP address is responding when running telnet from the client.

- On the server, set

IPAddress = "<The_working_IP_Address>"

in tm1s.cfg

- Restart TM1 Server

Notes :

- in some cases another solution is to set IPVersion = dual

- in Planning Analytics Local, IPAddress parameter is replaced by IPAddressV4 and IPAddressV6

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.2","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22010949