IBM Support

Client hangs/freezes "Not Responding" when click "Transfer - Publish data and structures - Define data mart", after creating new data mart, caused by APAR PH27153

Troubleshooting


Problem

User clicks "Transfer - Publish data and structures - Define data mart". 
  • Initially the screen appears as expected (everything works as normal).
User selects an existing data mart, and clicks 'Save As'. User chooses a new name, and presses 'Save'.
=> The Controller client hangs (saying 'Not Responding').
This seems to last forever (for example they can wait 30 minutes or so). If the user forcibly ends the CCR.EXE session, and re-opens the same menu item ("Transfer - Publish data and structures - Define data mart") then none of the data mart information appears.
  • Instead, everything looks empty/blank.

Symptom

Example:
User opens the menu item, and chooses an existing data mart (for example 'CBI').
  • User clicks 'Save As':
image 4925
User chooses a new name, and presses 'Tick' button:
image 4926
=> The Controller client hangs (saying 'Not Responding'):
 image 4933
This seems to last forever (for example at lest 30 minutes with no change).
If the user forcibly ends the CCR.EXE session...
image 4934
...then re-opens the same menu item ("Transfer - Publish data and structures - Define data mart") then none of the data mart information appears.
  • Instead, everything looks empty/blank:
image 4935
  
In addition, the Controller client says 'Not Responding' (see above).

Cause

Defect (reference APAR PH27153) in Controller 10.4.1 IF3 (10.4.1100.150) and later versions of 10.4.1.x.
  • This causes a SQL query to run with an infinite loop (neverending SQL process). This process only ends when the SQL server is restarted.
  
Example:
In one real-life example:
  • Everything worked OK when using Controller 10.4.1 RTM (10.4.1100.133)
  • The problem started after upgrading/patching to  Controller 10.4.1 IF4 (10.4.1100.158)

Resolving The Problem

Fix:
Upgrade to Cognos Controller 10.4.1 IF10 or 10.4.2 IF8, which contains a fix for APAR PH27153.
Log a Support Case to request access to the appropriate interim fix (the one matching your current version of Cognos Controller).
Then:
  • Obtain downtime (nobody using the system)
  • VITAL: Restart the Microsoft SQL database server (to end the looping SQL query)
  • Upgrade to the later version of Controller.
Workaround:
Downgrade to Controller 10.4.1 IF2 or 10.4.2 IF2 (where issue did not exist).

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"ARM Category":[{"code":"a8m50000000KzNaAAK","label":"Publish Data (DM)"}],"ARM Case Number":"TS003899116","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
31 May 2021

UID

ibm16244110