Troubleshooting
Problem
A Tivoli Storage Manager backup-archive client is enabled for client-side data deduplication but no file is deduplicated. No error is logged.
Symptom
The client backup statistics show :
Total number of objects inspected: 1
Total number of objects backed up: 1
Total number of objects updated: 0
Total number of objects rebound: 0
Total number of objects deleted: 0
Total number of objects expired: 0
Total number of objects failed: 0
Total number of objects encrypted: 0
Total objects deduplicated: 0
Cause
Simultaneous write is used on the server.
Diagnosing The Problem
In this example, the client uses the DEDUPPOOL storage pool for its destination storage pool. Examine the storage pool by using the "QUERY STG <NAME> F=D" command. For example :
tsm: MYTSM>q stg deduppool f=d
Storage Pool Name: DEDUPPOOL
Storage Pool Type: Primary
Device Class Name: FILE
...
Copy Storage Pool(s):
Active Data Pool(s): ACTIVEPOOL
The QUERY STG output shows that an Active Data Pool (ACTIVEPOOL) is configured for simultaneous-write. This configuration prevents client-side deduplication.
Resolving The Problem
A client that backs up data to a storage pool that is enabled for both deduplication and simultaneous write will not deduplicate data. This is one of the Data deduplication limitations. The following operations preempt client-side data deduplication:
- LAN-free data movement
- Subfile backup operations
- Simultaneous-write operations
- Server-initiated sessions
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21690817