IBM Support

A charge request is generated when order does not have a valid authorization ID

Troubleshooting


Problem

Attempts to generate shipment invoice generates a charge request without authorization in IBM Sterling Order Management..

Symptom

Sterling generates a CHARGE request even though the order does not contain a valid Authorization ID.
If the shipment invoice is generated before the Authorization request is successfully completed, Sterling generates a charge request and closes the authorization request without getting the authorization id from third party system.

Cause

This is working as designed.

Resolving The Problem

Sterling creates a charge request without an authorization ID if there is an invoice on the system that needs to be charged. This is to avoid delays in settlement and also to support auth-and-settle in one transaction, which many payment gateways support. If the payment gateway does not support it, then you can still perform authorization and a settlement in the collection credit card UE.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.4;9.3;9.2.1;9.2;9.1;9.0","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21976292