Troubleshooting
Problem
User runs any 'Standard Report'. By default, this will appear with 'Select Format' set to 'HTML'.
- The report appears OK (in HTML) in the standard report's browser window
- The report also simultaneously appears (outside the browser window) in a separate Adobe Reader session (as a PDF file).
User closes Adobe Reader (closes the PDF file). User then changes the 'Select Format' setting to 'PDF'. The report does not appear (in the 'standard report' browser window). Instead, that window is empty/blank.
Symptom
Initially, the report appears simultaneously as both HTML (inside the standard report browser) and also as a 'New_Report(x).pdf' file inside Adobe Acrobat Reader (separate from the Controller application):
If the user closes 'Adobe Reader' and then changes the 'Select Format' to 'PDF' then a white / blank / empty screen appears:
Cause
Adobe Reader is configured to not 'display PDF documents in the web browser':
Environment
The problem has been seen with Controller 10.3.1 and Adobe Reader XI, but it may affect other environments.
Resolving The Problem
Fix:
Reconfigure Adobe Reader to display PDF files in the Web browser.
- The steps vary depending on the version of Adobe Reader installed on the client device.
- For more information, see separate IBM Technote #6209640.
Steps:
The following is based on Adobe Reader XI:
1. Launch Adobe Reader
2. Click "Edit - Accessibility - Setup Assistant':
3. Click: Next, Next, Next, Next
4. Tick the box "Display PDF documents in the web browser"
5. Click Done
6. Test.
Workaround:
Reconfigure Controller to not produce a PDF file simultaneously (when the initial HTML file is rendered) by using the undocumented local preference 'StandardReportBackProc'.
Steps:
See separate IBM Technote #1364719.
Related Information
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Document Information
Modified date:
15 May 2020
UID
ibm10731979